Nexthink Service Degradation: DEX score is not visible

Incident Report for lew-nxt.statuspage

Resolved

We can confirm that the DEX Score visibility issue has been resolved. We appreciate your patience during this time.
Posted Mar 20, 2026 - 06:51 UTC

Monitoring

The issue affecting DEX Score visibility has been resolved, and we are continuing to monitor the system closely to ensure stability. We appreciate your patience and understanding.
Posted Mar 19, 2026 - 07:59 UTC

Investigating

We are aware of a degraded performance issue affecting Experience Central, causing the DEX score to be temporarily unavailable for some users. Our engineering team is actively working on a resolution. Thank you for your patience and understanding.
Posted Mar 19, 2026 - 06:34 UTC