Nexthink scheduled upgrade maintenance

Scheduled for May 7, 02:00 - 06:00 UTC

Update

Dear customer,
the maintenance date/time has been updated as follows:
---
Wed 7 May 04:00AM-08:00AM CEST(02:00AM-06:00AM UTC)
---
Posted Apr 29, 2025 - 13:33 UTC

Scheduled

Your Nexthink environment will be updated to version 2025.4:

Wed 7 May 04:00AM-08:00AM CEST(02:00AM-06:00AM UTC)

This update is non-disruptive and no downtime is expected.
Posted Apr 28, 2025 - 09:08 UTC