Nexthink Service Degradation: The Flow module is not visible in the UI

Incident Report for lew-nxt.statuspage

Resolved

We can confirm that the Flow icon has been restored on the UI menu. Our apologies for the inconvenience and thank you for your patience.
Posted Jun 18, 2025 - 14:43 UTC

Investigating

We are an investigating an issue where the Flow icon is not visible in the UI menu. Thank you for your patience.
Posted Jun 18, 2025 - 14:20 UTC